Author Topic: [ff4kster] Missing Portrait / Menu Freeze Glitch + Warp Glitch (FIXED)  (Read 113 times)

Spindaboy

  • Guard Leader
  • *
  • Posts: 52
  • Gender: Male
  • I need more sleep.
    • View Profile
    • SyndROMe Hacking
I've no idea why, but I guess I fucked something up real bad because the characters' portraits won't load in the menu. Attempting to select status, magic, etc. will soft lock the game because the cursor just disappears instead of appearing on a character. Anyone know what the issue could be...?


DK Cecil is dummied on purpose for my WIP hack. That isn't part of the issue just FYI.


EDIT: I manually copied over only the portions I had modified over from the broken ROM to a new ROM. When I loaded it into an emulator it was fine, however loading it in ff4kster and saving WITHOUT making any changes still corrupted it when I opened it in the emulator again. I guess ff4kster doesn't make some change I made I just have no idea what that change is.

EDIT #2: Now loading a perfectly fine ROM (that is headered) and has only had the Project II base patch applied to is also fucked. I have no idea wth is going on. I'll load up the perfectly fine ROM in ff4kster, make no changes, then save. But when I open it again in game now all the warps take me to the very top left corner of Baron. It doesn't matter if I walk into Baron Castle, Mist Cave, etc. they all take me to the corner of Baron. I tried re downloading ff4kster and the Project II patch which also didn't do shit. If anyone knows what in the fuck is happening then please let me know because I am losing my mind trying to figure it out.


EDIT #3: Still trying to resolve the issue. Only progress I've made is that when investigating the "Map" portion of ff4kster (while using the Project II patch, but before saving in the editor) I found that the text near the end of the menu is red and says "Over: 377" which does not occur before applying the patch. What confuses me to no end is that I have used multiple ROMs in the past that have been patched using the same Project II ips with no issues whatsoever. In fact, the ROM that I originally had the missing portrait bug with still has no warping issues even after being saved in ff4kster again. I swear I have run every single possibility through my mind yet still turned up nothing. I honestly want to give up after wasting so much time on this with no resolution in sight.


EDIT #4: Finally fixed the issues! I'll explain how in case anyone else ever reads this.
Problem #1: Not exactly sure why this one was caused, however I do know it has to do with spell data. My theory is that it was likely because I changed the amount of 6 letter spells.
Problem #2: Deleting unnecessary map data to make more room solved the problem. Just make sure you aren't over the limit when you save in the editor!
« Last Edit: August 09, 2017, 02:12:17 PM by Spindaboy »